L1-064 估值一亿的AI核心代码 (20分)

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don ‘t know
 

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don ‘t know
AI: what Is this prime! you,don‘t know代码:
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Scanner;
import java.util.StringTokenizer;

/**
* @author 邢兵
* @data
* @description
*/
public class L1064 {
static class Reader{
static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
static StringTokenizer tokenizer = new StringTokenizer("");
static String nextLine() throws IOException{
return reader.readLine();
}
static String next() throws IOException{
while(!tokenizer.hasMoreTokens()){
tokenizer = new StringTokenizer(reader.readLine());
}
return tokenizer.nextToken();
}
static int nextInt() throws NumberFormatException, IOException{
return Integer.parseInt(next());
}
}
public static void main(String[] args) throws IOException {
int n = Reader.nextInt();
for(int i=0;i<n;i++){
String str = Reader.nextLine();
char chars[] = str.toCharArray();
String str1="";
//除I之外的大写字母全部转换为小写字母
for(int j=0;j<chars.length;j++){
if(chars[j]>=‘A‘&&chars[j]<=‘Z‘&&chars[j]!=‘I‘){
chars[j]+=32;
}
str1+=chars[j];
}
//将多余空格全部转换为一个空格
str1 = str1.replaceAll("\\s+", " ");
//去除字符串首位空格
str1 = str1.trim();
//删除标点符号前面的空格
str1 = str1.replaceAll(" (\\W)", "$1");
//把所有的?换为!
str1 = str1.replace("?", "!");
str1 = str1.replaceAll("\\bcan you\\b", "A");
str1 = str1.replaceAll("\\bcould you\\b", "B");
str1 = str1.replaceAll("\\b(I|me)\\b", "C");
str1 = str1.replaceAll("A", "I can");
str1 = str1.replaceAll("B", "I could");
str1 = str1.replaceAll("C", "you");
System.out.println(str);
System.out.println("AI: "+str1);


}
}
}

 

相关推荐