在Mac OS X 10.5.5上安装iPhone SDK 4.0.2的办法

      由于老乔的偏执和自负,他领导下开发出来的东东跟他一样的臭脾气,iPhone SDK非得要认定操作系统的版本号,版本号不满足要求就不让装。在我朝,花血本买个水 果 机已经是着实不易了,还非得让咱们跟着老乔的步子不停地往里砸钱不可。我可是穷人,不仅买不起水 果 机,连配置高一点的PC都买不起。所以只能找了台服务器跑个虚拟机来尝尝水果的味道。可我的虚拟安装的Mac OS X 10.5.5竟然不让安装iPhone SDK 4.0.2。不让装高版本SDK也还罢了,竟然低版本的SDK也不让下载了,火大!因为找不到低版本的SDK,所以尝鲜的梦想只能暂时放弃了,望果兴叹!

       今天偶然在网上发现有人说可以修改Mac OS X的版本号,让我重新有了安装iPhone SDK 4.0.2的冲动。按照网上的说法一步步照做:

一、打开控制台(或者ssh登录到Mac上);

二、切换到root用户(不切换的话无权限修改版本文件);

三、编辑 /System/Library/CoreServices/SystemVersion.plist 文件,在编辑前先备份一个:

cp /System/Library/CoreServices/SystemVersion.plist /System/Library/CoreServices/SystemVersion.plist.20100908

vi /System/Library/CoreServices/SystemVersion.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/
PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
        <key>ProductBuildVersion</key>
        <string>9F33</string>
        <key>ProductCopyright</key>
        <string>1983-2008 Apple Inc.</string>
        <key>ProductName</key>
        <string>Mac OS X</string>
        <key>ProductUserVisibleVersion</key>
        <!--string>10.5.5</string-->
        <string>10.6.2</string>
        <key>ProductVersion</key>
        <!--string>10.5.5</string-->
        <string>10.6.2</string>
</dict>
</plist>

其中注释掉的10.5.5是Mac OS X的真实版本号,10.6.2是iPhone SDK 4.0.2要求的版本号。改完后保存并退出。

四、启动 xcode_3.2.3_and_ios_sdk_4.0.2.dmg,按照提示一步步往下安装,没提示版本不符了。

写这些文字的时候,正在安装中,至于装完能不能用,只能等到装完再见分晓了。

===============================

经过N(N>5)次试装,终于发现是都是徒劳,修改了版本还是无法安装xcode_3.2.3_and_ios_sdk_4.0.2.dmg。最后是从网上找来一个iphone_sdk_3.1.3_with_xcode_3.1.4_leopard_9m2809a.dmg,顺利安装成功。还未试用。

=========================================

=========================================

附:

在没有安装显卡驱动的虚拟机中修改分辨率的办法:

1、打开终端,输入 sudo -s,取得root权限;

2、输入 vi /Library/Preferences/SystemConfiguration/com.apple.Boot.plist,打开该文件;

3、在

<key>Timeout</key> <string>10</string>

的下面添加如下两行:

<key>Graphics Mode</key> <string>1280*800*32@60</string>

然后保存,退出, 我的PC是1280X800的本本,刷新率为60,没发现有异常,你可以更改为需要的值。

4、重起。

相关推荐